?

Log in

No account? Create an account

December 18th, 2005

Updates 4 Laptop

Wow! Three months of pent-up Linux upgrades unleashed in three days! I got alot accomplished sitting through the fury with a fellow hacker (my roomie) in the living room until:

Successes
webcam streams via usb
recomplied kernel with v4l and ibmcam, the later (magically) loads usbvideo and videodev modules
tested with my roomie’s Xirlink/Veo Stingray
GQcam displays stream; also encoded stream to an .avi movie with mencoder!
digital camera uploads via usb
bus simply recognized device because kernel compiled with usb-storage (aka. sg, sd_mod not needed)
tested with my roomie’s Kodak CX4200
because test camera is PTP compliant, gphoto2 and GTkam easily upload images
TV-Out displays through S-Video port
ummm, I fummbled through this one because I use ati-drivers (fglrx module) so here’s my best explanation. Everyone uses atitvout and curses the proprietary drivers. Oh well... I want native 3D acceleration dammit! ;) My roomie got his ATI working even while using radeon drivers after copying my xorg.conf edits, and those changes were:

< Section "Monitor"
< Identifier "TV-Out"
< Option "DPMS"
< HorizSync 31.5-68.7
< VertRefresh 60-85
< EndSection
...
< Option "DesktopSetup" "Clone"
< Option "MonitorLayout" "TMDS, AUTO"
< Option "NoTV" "no"
< Option "TVStandard" "NTSC-M"
...
< Section "Screen"
< Identifier "Screen1"
< Device "ATI Graphics Adapter"
< Monitor "TV-Out"
< DefaultDepth 24
< Subsection "Display"
< Depth 24
< Modes "800x600" "640x480"
< ViewPort 0 0
< EndSubsection
< EndSection

there's output to the TV only when the s-video cable is connected at bootup, and the output is a clone of my X session per the configuration Option
emerged latest ati-drivers
timidity (midi) emulator plays
recompiled... something with +timidity USE flag
many thanks to Adam's Sarah who wanted to hear Christams Carols as MIDI's
oss emulation for dosbox works
switched to the latest alsa-utils for kernel-2.6.12 with intel8x0 module
volume levels now stored at shutdown with the alsasound script
syncing to palm again
pilot-link and jpilot correctly negotiate serial connections at 57600kbps to my aging Palm VIIx
seems the serial port always worked and I didn't need to fiddle with minicom or setserial!
reinstalled the micro innovations driver so I can type using IR with my PDA! very cool!!
wireless networking script connects!!
reconfigured wpa_supplicant -- again -- without luck :(
found bug with dhcpcd or wireless-tools so changed the dhcp client to dhclient, and BINGO! fixed
tested against 64-bit WEP key and unencrypted AP
compiled OpenOffice-2
emerge took 12 freekin' hours! and overheated my system twice! :|
installed Ephemeris for astronomy work
installed Xplanet for astronomy play :)
Maple update
Maple Help:About claims it is version 9.03
and... the maplesoft technician said Gentoo is not supported... LOL! OK, so the error is still there.

Failures

Wine with DirectX9
winex-cvs with d3d9 profile compiles successfully but the executable fails with some library not found. I need to
purge previous versions...
gift P2P
giftd runs but cannot connect the gnutella or openfast networks
XMMS
@uc*$ng still $hi8 not working! UGH!